Har du en router fra UniFi og ønsker at den skal virke med Altibox sin TV løsning?

Long time no see

Fire år siden sist jeg skrev et innlegg på bloggen. En av de postene jeg fikk mest respons på tidligere var oppskriften på hvordan man kunne benytte iPhonen en enhet med flere pcer. Vi skriver nå 2020, oppskriften er sikkert for lengst utdatert. Dessuten har vi fått familiedeling.

Det var først i 2012 vi fikk installert fiber fra Altibox etter et tilbud jeg ikke kunne avslå. Fiber ble installert kostnadsfritt mot at vi tegnet et av deres produkter. Før det benyttet vi hovedsak internett gjennom mobiltelefonen, dette gav bedre nett enn ADSL. Med fiber ble det en ny virkelighet. Fra første dag ble hjemmesentralen til Altibox pensjonert. Først av en trofast Asus AC66u som jeg fremdeles benytter som switch og wifi sender, deretter av en UniFi USG Pro 4 router.

UniFi sin router har mer en nok muligheter for «mannen i gaten», faktisk krever den at man er lærevillig og har litt nettverksforståelse, du burde heller ikke være redd for å skrive tekstkommandoer eller uttrykk som CLI og SSH. Det vil nok de fleste som har, eller kjøper, et produkt fra UniFi vedkjenne seg.

Sommeren 2018 oppgraderte jeg min Motorola tv- dekoder med en Huawei Q-22. Siden den nye dekoderen krevde både tilgang til internett og Altibox sin IPTV løsning på samme tid var det på tide å sette opp en ny løsning. Som nevnt falt valget på UniFi.

Hjelp, routeren virker ikke. Eller hvordan forberede oppsett av routeren.

Det første man vil merke er at routeren ikke vil virke ut av boksen, den må settes opp eller konfigureres. Har du tidligere fulgt guiden under anbefaler jeg at du også leser dette innleget hvis du ikke får til tv- løsningen.


Før vi starter med oppsettet vil jeg starte litt med å forklare hvordan Altibox har delt opp sitt nett i VLAN. Kort og enkelt forklart betyr VLAN at man deler opp nettverk i flere underliggende nett. Dette gjør at du kan for eksempel ha dine små dingser på eget nett,gjestenettverk på et annet og ditt hovednetktverk på et tredje.

Altibox har delt opp sitt nett i følgende VLAN:
100: Ip- telefon og konfigurasjon av hjemmesentral
101: IPTV-tjenesten til Altibox
102: Internett

Utfordringen med den UniFi routeren jeg har er at den ikke støtter flere VLAN hvis man kun skal sette den opp via kontrollerprogramvaren/ grensesnittet. Dette gjør at man også må benytte seg av CLI, eller (kommando)linjegrensesnittet. Dette fordrer at man benytter seg av terminalprogrammet hvis man kjører *nix eller cmd hvis man har Windows. I resten av denne artikkelen går jeg ut i fra at du kan benytte deg disse programmene. Man må også finne ut av hva portene på routeren heter slik at man vet hva som er eth0, eth1 etc.


Først kommer internett
Det første man må gjøre er å sette opp internett. Dette sikrer også at man vet at router og linje fungerer.

Det letteste man gjør er å aktivere VLAN og sette VLAN ID til 102 i grensesnitet. Internett kan også settes opp manuelt ved å benytte CLI slik i beskrivelsen under. Jeg går ut i fra at du vet hvordan du kommer inn i konfigurasjonsmodus ved å skrive configure etter at du er logget inn.

Først må man aktivere VLAN 102 under riktig port på routeren, på min router er det eth2 der signalene kommer inn gjennom en SFP modul.

Først skriver man følgende kommandoer for å sette opp VLAN 102:

set interfaces ethernet eth2 vif 102 description «Internett» -> Du kan kalle det for hva du vil, jeg kaller det for Internett.

set interfaces ethernet eth2 vif 102 address dhcp -> Aktiverer DHCP server

set interfaces ethernet eth2 vif 102 firewall in name WAN_IN 

set interfaces ethernet eth2 vif 102 firewall local name WAN_LOCAL

Når det er gjort må Masquerade settes opp slik at du kan dele internett med enhetene som skal kobles opp (merk at du kan tilpasse postnummer til din egen installasjon):

set service NAT rule 5000 description «Masquerade LAN to WAN»

set service NAT rule 5000 log disable

set service NAT rule 5000 outbound-interface eth2.102

set service NAT rule 5000 protocol all

set service NAT rule 5000 source address 192.168.1.0/24 -> eventuelt kan du sette opp 0.0.0.0/0 som vil åpne opp for alle underliggende nettverk hvis du har flere undernettverk.

set service NAT rule 5000 type masquerade

Når dette er gjort kan du skrive commit og trykke enter for deretter å avslutte med save exit.

Når du er ute kan du skrive følgende for å sjekke om du får nettverksadresse:

renew dhcp interface eth2.102

deretter

show interfaces

Du vil da se eth2.102 med en ip-adresse og Internet ti beskrivelsesfeltet.

Klar for å sette opp TV

Neste oppgave blir å sette opp TV, her ser jeg at en del sliter med på ulike fora. Uansett er mitt oppsett slik at jeg lar internett og tv gå via samme kabel. Skal du ha tv ut på en annen port må du tilpasse dette i ditt oppsett,

Skriv configure for å gå inn i konfgurasjoinsmodus og skriv inn følgene kommandoer:
set interfaces ethernet eth2 vif 101 description «IPTV»-> Kan kalle det du vil.

set interfaces ethernet eth2 vif 101 address dhcp -> Aktiverer dhcp

set interfaces ethernet eth2 vif 101 mac 00:AA:CC:EE:11 -> Her setter du inn mac- adressen til din Altibox- hjemmesentral. Du vil ikke få TV- delen til å virke uten at du gjør dette.

set interfaces ethernet eth2 vif 101 dhcp-options default-route no-update

set interfaces ethernet eth2 vif 101 dhcp-options default-route-distance 210

set interfaces ethernet eth2 vif 101 dhcp-options name-server update

Når dette er gjort kan du kjøre en commit og deretter save for feilsøking og lagring av det du har gjort, men er ikke nødvendig.

Deretter settes opp Masquerade:

set service nat rule 5001 destination address 172.21.0.0/16
set service nat rule 5001 log disable
set service nat rule 5001 outbound-interface eth2.101
set service nat rule 5001 protocol all 
set service nat rule 5001 type masquerade

Når dette er gjort kan du kjøre en commit og deretter save for feilsøking og lagring av det du har gjort, men er ikke nødvendig.

Så må du sette opp IGMP- PROXY
set protocols igmp-proxy interface eth0 alt-subnet 192.168.1.1/24->Eventuelt kan det settes opp med 0.0.0.0/0

set protocols igmp-proxy interface eth0 role downstream -> Den porten (og lanet) du ønsket signalene sendt til.

set protocols igmp-proxy interface eth0 threshold 1

set protocols igmp-proxy interface eth2.101 alt-subnet 172.21.0.0/16

set protocols igmp-proxy interface eth2.101 role upstream
set protocols igmp-proxy interface eth2.101 threshold 1

Nå kjører du commit og deretter save exit for å gå ut av konfigurasjonsmodus.

Når du er i hovedmenuen skriver du inn:

renew dhcp interface eth2.102
show dhcp client leases interface eth2.101

Du vil da få opp en del informasjon, men det vi er ute etter er adressen som står etter «router». Skriv ned denne ip- adressen slik at du husker den.

Deretter skriver du configure og skriver inn følgende kommando:

set protocols static route 172.21.0.0/16 next-hop xx.xx.xx.xx distance 1-> Router- adressen som ble skrevet ned i forrige skritt skal skrives inn der det står x. 172.21.0.0/16 kan byttes ut med 0.0.0.0/0 som åpner opp for hele lanet (noe jeg ikke anbefaler).

Til slutt er det bare å sette opp riktig kildevalidering i brannmuren slik at ting ikke hakker etter +/- 30 sekunder.

set firewall source-validation loose -> Du kan benytte disable istedenfor losse, men det anbefales ikke da du slår sikkerhetsfunksjonen helt av.

Til slutt gjenstår det følgende:

Skriv inn commit, deretter save exit.

Sett opp config.gateway.json fil

Oppdatering 21. januar 21:

Tidligere innlegg beskrev hvordan internett og tv-løsning kunne benyttes på en UniFi router uten at man hadde behov for Altibox sin hjemmesentral. Dette gav en mulighet for å kutte ut boksen man fikk fra Altibox. Men ikke kast den gamle hjemmesentralen, den er Altibox sin eiendom. Etter at jeg skrev forrige guide har Altibox endret sin tv- løsning noe. Du må derfor i tillegg til tidligere guide også følge denne.

Følg guiden jeg lagde tidligere, deretter logg inn i din unifi controller. Gå til «Advanced Featuered»-> «Advanced Gateway Settings»-> Static Routes-> Create new Statoil route. for å legge inn følgende informasjon:

Name: Her kan du angi et passende navn

Network subnet address: 10.133.0.0/16 

Distance: 1

Static route type: Nexthop 10.168.66.1

Next hop: 10.168.66.1

Ønsker du ikke å logge inn i controller kan du forsøke å skrive følgende i CLI:
set protocols static route 10.133.0.0/16 next-hop 10.168.66.1 distance 1













14 tanker om “Har du en router fra UniFi og ønsker at den skal virke med Altibox sin TV løsning?

  1. hei kunne du vist eit eksempel på Config.gateway.json , jeg får den ikke til heilt, er det noen enkel måte å gjøre det på

  2. Hmmmm. Når jeg kommer igjennom hele TV-oppsettet fungerer det, altiboxene får IP fra lokalnettet (10.0.0.x) som alt annet og leverer alle tjenestene de skal. I første omgang satte jeg igmp-proxy interface eth0 alt-subnet til 192.168.1.1/24 og opplevde noen litt rare ting (rød internettboble i UniFi), men i omgang to satte jeg den til 10.0.0.1 og det set ut til å fungere helt fint nå (hvit boble).

    Er dette slik det er tenkt?

    Det jeg sitter helt fast på nå er JSON-biten. Jeg har et tekst-dokument med alle innstillingene jeg bare kan kopiere og dumpe i SSH, men det blir jo tungvint… Jeg hentet ut config.boot fra USG4’en, men den ser ut til å inneholde mye mer enn det jeg forstår config.gateway.json burde og jeg forstår ikke json nok til å vite hvor(dan) jeg skal klippe å lime den sammen..

  3. Hei,

    ja siden du har endret fra 192.168.x.x til 10.0.0.x så har du gjort det korrekt.

    Skal se om jeg kan få laget en guide på json- biten også, men da så lett at flest mulig kan ta det i bruk.

    Kristian

  4. Hei,

    ja skal se om jeg ikke får til en guide på det også etter hvert. Mitt tips er at du bruker en Json- editor som gjør det litt lettere.

    Kristian

  5. Hei, veldig takknemlig for veiledningen. Kjøpte UniFi Security Gateway 4P og en Unify 8P switch etter at jeg leste denne guiden. Er mest kjent med Cisco så man må først ble kjent med måten Ubiquiti fungerer. Man begynner med å lage et konto hos Ubiquiti her: https://account.ui.com/
    Man laster ned Unifi Network Controller her: https://www.ui.com/download/unifi/#
    Installer Network Controller på en laptop og start Controller App og login med samme brukernavn og passord som du laget nettopp.
    Koble til samme laptop via LAN kabel til LAN1 port på USG. Etter kort tid vil USG dukke opp på dashboard. Du kan nå velge Adopt for å legge til USG til Network Controller. Nå velger du Settings > Site og under Services enabler du Advanced Features. Velg deretter Save. Nå kan du endre passord nederst på siden under device Authentication for bruker. Etter det bruker man Putty med disse credentials (Usernavn er case sensitive!) til default IP på USG, 192.168.1.1
    Du taster inn confugure og deretter følger du denne guiden for å konfigurere internet fra Altibox og deretter IPTV. Lager man ingen json fil vil alle endringer forsvinne etter første omstart. Å lagre hele konfigurasjon er enkelt. Via Putty taster man følgende kommando:

    mca-ctrl -t dump-cfg > config.txt

    nå bruker man en secure FTP klient som WINSCP. Tast in 192.168.1.1 som adresse og bruk din USG brukernavn og password. Last ned config.txt til din pc og endre navn til config.gateway.json

    har du Windows 10 navigerer du til C:\Users\din_bruker_navn\Ubiquiti UniFi\data

    hos meg ble ikke noen sites mappe laget., er dette tilfelle hos deg lag en mappe «sites»

    Under sites må du lage en mappe med site name. Du finner den ved å se på URI til Unifi Network Controller:

    https://localhost:8443/manage/site/default

    Hos meg er site navnet «default», så lag en mappe som du kaller default under sites. Deretter har du:
    C:\Users\brukernavnxxx\Ubiquiti UniFi\data\sites\default

    i denne mappe kopierer du config.gateway.json

    Deretter velger du Devices i venstre panel i Controller og under Config > Manage Device og her trykker du på Provision (Force Provision). Din json fil ble lest og lagret som boot config. Deretter vil konfigurasjonen «overleve» reboots.

  6. Info som jeg skrev før om json filen var kun delvis riktig. Vurderer man å kjøpe USG Pro 4 anbefaler jeg at man enabler Advanced features og kobler Putty på USG. Deretter skriver du mca-ctrl -t dump-cfg > config.txt og bruker WinSCP til å hente ut config.txt filen. Denne bruker du som startreferanse. Du følger forfatterens veiledning frem til «Klar for sette opp TV». Du skriver commit save exit og deretter mca-ctrl -t dump-cfg > config1.txt. Hent filen med WinSCP. Jeg brukte Total Commander til å sammenligne config.txt og config1.txt. Forskjell vises i rød. Du begynner nå å lage din json fil. Jeg brukte Notepad++, og bruk denne som guide: https://help.ui.com/hc/en-us/articles/215458888-UniFi-USG-Advanced-Configuration-Using-config-gateway-json
    Husk å legge til alle } og }, og kopier fra config1.txt kun endringer iht config.txt. Disse endringer skal dekke den delen av veiledningen frem til «Klar for å sette opp TV». Når du er ferdig lagrer du filen som config.gateway.json i C:\Users\brukernavnxxx\Ubiquiti UniFi\data\sites\default.
    Nå tester du om du ikke har glemt et tegn eller noe ved å lime in innhold fra filen i https://jsonlint.com/
    Når Validate Json gir «valid JSON» oppdaterer du din json fil eller hvis den gikk gjennom uten endringer trenger du ikke å gjøre noe. I Unifi Controller tar du nå en Force Provision. Går status etter litt tid over fra Provisioning til Connected er alt sweet. Du kan nå begynne å sette opp IPTV delen. Oppdater konfigurasjonen via Putty litt og litt. Commit save exit og lag config2.txt, config3.txt og bruk Total Commander til å finne de siste endringer som du legger til i din json fil. Test filen og force provision.

    Jeg likte internet og iptv via egne porter (LAN1 og LAN2) LAN 2 må aktiveres først ved å lage eget nettverk. Via putty må man i configure mode skrive delete interfaces ethernet eth1 state down for å aktivere LAN2.

    Her er min komplette json fil som fungerer perfekt:

    {
    «interfaces»: {
    «ethernet»: {
    «eth1»: {
    «address»: [
    «192.168.2.1/24»
    ],
    «description»: «IPTV»,
    «duplex»: «auto»,
    «firewall»: {
    «in»: {
    «ipv6-name»: «LANv6_IN»,
    «name»: «LAN_IN»
    },
    «local»: {
    «ipv6-name»: «LANv6_LOCAL»,
    «name»: «LAN_LOCAL»
    },
    «out»: {
    «ipv6-name»: «LANv6_OUT»,
    «name»: «LAN_OUT»
    }
    },
    «speed»: «auto»
    },
    «eth2»: {
    «speed»: «auto»,
    «vif»: {
    «100»: {
    «description»: «ALTIBOX_MGMNT»,
    «mtu»: «1500»
    },
    «101»: {
    «address»: [
    «dhcp»
    ],
    «description»: «IPTV»,
    «dhcp-options»: {
    «default-route»: «no-update»,
    «default-route-distance»: «210»,
    «name-server»: «update»
    },
    «mac»: «54:83:3A:D0:72:A5»
    },
    «102»: {
    «address»: [
    «dhcp»
    ],
    «description»: «ALTIBOX INTERNET»,
    «firewall»: {
    «in»: {
    «name»: «WAN_IN»
    },
    «local»: {
    «name»: «WAN_LOCAL»
    }
    }
    }
    }
    }
    }
    },
    «protocols»: {
    «igmp-proxy»: {
    «interface»: {
    «eth1»: {
    «alt-subnet»: [
    «0.0.0.0/0»
    ],
    «role»: «downstream»,
    «threshold»: «1»
    },
    «eth2.101»: {
    «alt-subnet»: [
    «172.21.0.0/16»
    ],
    «role»: «upstream»,
    «threshold»: «1»
    }
    }
    },
    «static»: {
    «route»: {
    «172.21.0.0/16»: {
    «next-hop»: {
    «10.171.102.1»: {
    «distance»: «1»
    }
    }
    }
    }
    }
    },
    «service»: {
    «nat»: {
    «rule»: {
    «5000»: {
    «description»: «MASQUERADE LAN TO WAN»,
    «log»: «disable»,
    «outbound-interface»: «eth2.102»,
    «protocol»: «all»,
    «source»: {
    «address»: «0.0.0.0/0»
    },
    «type»: «masquerade»
    },
    «5001»: {
    «description»: «MASQUERADE FOR TV WAN»,
    «destination»: {
    «address»: «172.21.0.0/16»
    },
    «log»: «disable»,
    «outbound-interface»: «eth2.101»,
    «protocol»: «all»,
    «type»: «masquerade»
    }
    }
    }
    }
    }

  7. Fungerer dette oppsettet for alle, med både tv og internett, også etter 28.august 2020, da det var stor nedetid eller kan evt altibox ha gjort noen endringer?

  8. Etter 30.august (2020) sluttet denne løsningen å funke… Det er kun NRK-kanalene som fungerer nå, og bytter jeg til noen andre, så fryser det helt, og jeg må restarte dekoderen, men det funker fremdeles ikke…
    Noen som har noen tips?

  9. Hei

    Jeg har en edgerouter x
    Ser i din fremgangsmåte du har kabel fra fiber inn i eth2. Hos meg er det inn på eth0.

    Ser da i ditt oppsett du bruker eth0 på tv biten. Kan jeg bare endre til eth1?

  10. Hei

    Takk for fin oppskrift.

    Etter oppsett så virker internett, men tv er ikke helt sammarbeidsvillig.
    Kun NRK kanalene som vil virke.

    Noen tips til hva som kan være galt da?
    Har Edgerouter-X

  11. Takk for flott guide! Fungerer helt strålende for NRK-kanalene, tv-guide, filmleie og kanalarkivet. Alle andre tv-kanaler enn NRK-kanalene laster ikke. Noen gode forslag til løsning?

  12. Hei.

    Har lagt inn konfig som vist over og får internett, men kun NRK-kanalene.
    Noen idè om hvorfor?

  13. Til dere som har problemer med NrK anbefaler jeg å logge inn i interfacet og legge inn følgende:

    Name: Kall det hva du vil

    Network subnet address: 10.133.0.0/16

    Distance: 1

    Static route type: Nexthop

    Next hop: 10.168.66.1

  14. Tilbaketråkk: Altibox – UniFi og TV | KVTLs hideout

Legg igjen en kommentar

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *